Go Back  Bike Forums > Search Forums
Reload this Page >

Search Results

Notices
Search: Posts Made By: dmanthree
Showing results 1 to 5 of 5
Search took 0.01 seconds.
08-20-19, 08:40 AM
Replies: 12
Views: 1,776
Posted By dmanthree

The final chapter: I sent the light to Nite...

The final chapter: I sent the light to Nite Rider, who replaced the battery for no charge. It was a dead battery, I guess.
08-11-19, 05:36 PM
Replies: 12
Views: 1,776
Posted By dmanthree

Either way, if I leave something permanently...

Either way, if I leave something permanently inserted it exposes the port to water damage. I really need to close that rubber flap.
08-09-19, 12:58 PM
Replies: 12
Views: 1,776
Posted By dmanthree

My 850 has the port under a rubber flap on the...

My 850 has the port under a rubber flap on the bottom. I have it mounted using a K Edge mount and gopro adapter, so the port faces up. The adapter won't work for me.
08-08-19, 10:24 AM
Replies: 12
Views: 1,776
Posted By dmanthree

Repair

Correct, it uses one of those worthless micro UB ports. A mini would have fit the space...

I sent it to Nite Rider for repair. It's a good light (when it works) and the repair quote was cheaper...
08-05-19, 04:34 PM
Replies: 12
Views: 1,776
Posted By dmanthree

Sudden Death of a Light?

I have a Nite Rider Lumina 850, and while it's been a good unit it just suddenly stopped working. It won't take a charge. Has anyone seen this? Any ideas on a cause?
Showing results 1 to 5 of 5


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.