View Single Post
Old 04-08-19, 03:57 AM
Join Date: Apr 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
The first time I tried to sync my Polar V650 it worked with the tip to first uninstall both bonjour and Polar flow sync programs and then reinstall Polar flow sync. The Polar V650 then synced nicely and updated the firmware. Then I used the V650 for one outdoor cycling training(45km) and then synced it via the Polar flow app on my iphone, which worked. But after that I could not get it to sync to any of my 3 computers again(one is a Mac). I tried every tip above, including trying to manually install the driver for Remote NDIS based internet sharing device manually, but keep getting error code 10 "cannot start device correctly".

I was just about to send the unit in to Polar, but when preparing for that I tried using the original usb micro cable supplied with the Polar V650 and it worked! I had used three different micro USB cables when problem solving, all cables are functional to other devices. So it seems that the Polar V650 is very sensitive to what USB cable that is used.

My tip: Only use the USB cable that was included in the polar V650 package.
Andreas74 is offline