Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

Polar v650 USB problem

Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

Polar v650 USB problem

Old 04-18-17, 10:23 AM
  #26  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
After setting the AV exclusions as shown above, the V650 was turned on, plugged into the PC via USB and it immediately crashed my Cisco Anyconnect VPN which I forgot was running. The VPN automatically reconnected and then the Flow app opened and synchronized without a problem.

This behavior was repeated several times. Every time I turn on the Polar and plug it in it synchronizes fine.

I'll probably reboot at some point today and test again.


-Tim-

Last edited by TimothyH; 04-18-17 at 10:27 AM.
TimothyH is offline  
Old 04-18-17, 03:43 PM
  #27  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
Rebooted and it worked perfectly.

Turned on the V650, plugged it in, flow opened and it started synchronizing.

Much thanks to @markss for mentioning antivirus.

-Tim-
TimothyH is offline  
Old 04-25-17, 06:45 AM
  #28  
markss
Newbie
 
Join Date: Apr 2017
Posts: 4
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Thanks Tim - I have set the folder exclusion in my Avast virus checker and disabling all of the shields is no longer required.
markss is offline  
Old 04-25-17, 07:36 AM
  #29  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
After a few days mine stopped automatically synchronizing again.
TimothyH is offline  
Old 04-29-17, 01:32 AM
  #30  
Brillowolf
Newbie
 
Brillowolf's Avatar
 
Join Date: Apr 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
One thing I've noticed is that after each training session, prior to syncing my V650, I have to power down the device and power it back up before plugging it into my laptop's usb. If I don't restart the ***t before attempting to sync, I get the frustrating can't connect messages. Hope that helps.
Brillowolf is offline  
Old 07-03-17, 10:09 AM
  #31  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
I can't recommend the Polar V650 any longer. Mine is bricked. The touch screen stopped working.

A hard reset didn't help. A reset to factory defaults took the device to the initial setup screen which requires the touch screen so I'm stuck.

I don't know if water is the cause but the device worked fine through a fast and rough gravel descent off a mountain in a torrential rainstorm, 1700 feet elevation loss over five miles. This was followed by another half hour in steady rain. The device synchronized when I got home, took a full charge and was put away. Two days later the touch screen would not respond.

At $169 and given the features, the Polar was an incredible value. There was one annoying synchronization bug but I've been very satisfied with the performance and hate to let it go.

Held my nose this morning and purchased a Garmin 820 at well over twice the price of the Polar. Paid retail at REI so that it can be returned if it fails.


-Tim-
TimothyH is offline  
Old 08-12-17, 02:16 PM
  #32  
OldCourierBob
Newbie
 
Join Date: Aug 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
About section in the Polar

Hi all,

I've been having Polar V650 issues also. I noticed that one thing to try that nobody mentioned is in the "About" section of the V650. You have the option there between Windows and Mac OS X.

However, having said that, I'm at an impasse with my Polar. Won't sync with my Mac anymore, after having done it nicely a bunch of times, nor will it sync with my Samsung Galaxy J3. They can see each other via Bluetooth, but I can't get my data from the Polar.

Does anyone know how to reset the Polar without having to go through the FlowSync application?
OldCourierBob is offline  
Old 08-12-17, 08:52 PM
  #33  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
Factory reset is to hold both the front and side buttons at the same time, ten seconds I think.

As an aside, I tried a Garmin Edge 820 hoping it would be similar to the Polar. I returned the Garmin and purchased a new Polar for less than half the price.


-Tim-
TimothyH is offline  
Old 09-29-17, 03:13 AM
  #34  
PeterAdams
Newbie
 
Join Date: Sep 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Polar V650 troubles

Hi,

I came across this thread when I was trying to find a solution for my sync problems with the Polar V650.

So far I tried everything that is mentioned on any website/forum without succes:
- order of starting up devices and PC
- other PC and Mac
- other USB cables
- deleting drivers
- antivirus off
- exceptions in antivirus

To be honest, I have to admit that 1 out of 250 tries I can synchronize the V650.
Why it happens on that occasion? I dunno ! If I try it in the same way again, it doesn't work...

So I read here that I should use the Polar Flow app on my Android phone and use the 'Sync with your phone' feature. I made a Bluetooth connection with the number verification and then finally got the msg: 'Synchronizing'
But a few seconds later: 'Synchronizing Failed' ... no reason given.

mmm try again... but now I'm unable to make a bluetooth connection.
Restart Polar device, restart Android.
Ok, made a connection... syncing... FAILED...

I tried... I tried, I really tried...
PeterAdams is offline  
Old 09-29-17, 07:30 AM
  #35  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
Delete the "NDIS Internet Sharing" device out of device manager. Start the Flow app, plug in the V650, turn it on and then tell device manager to "scan for hardware changes." It will discover the device, install a driver and start synchronizing.

Or just sync with a phone.
TimothyH is offline  
Old 10-01-17, 08:51 PM
  #36  
Specializedman1
Newbie
 
Join Date: Nov 2016
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
v650

I've had I've had the same problem with five computers now I have one laptop that works I used to use my S5 and then I upgraded to the S7 it worked for three months until T-Mobile did an update on the software and it has not worked since it's been 8 months polar has been no help they sent me a new ***t it still does not work they have a problem with Samsung phones and they won't admit it
Specializedman1 is offline  
Old 10-02-17, 06:55 PM
  #37  
Baldy1953
Senior Member
 
Join Date: Aug 2014
Posts: 191
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Likes: 0
Liked 1 Time in 1 Post
I think the problem could lie with Polar. I have an M400 that will not accept a charge or get recognized by Polar in Polar Sync. finally gave up after fighting with it for over a year. Replaced multiple USB cords and sent the Polar back to them for repair under warranty.
Now have a Suunto ambit3 Peak and so far it works as advertised. (steep learning curve though)
Polar ought to get with the program and put our a product people don't have to struggle to get to work properly.
Baldy1953 is offline  
Old 10-09-17, 04:42 AM
  #38  
markss
Newbie
 
Join Date: Apr 2017
Posts: 4
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
V650 sync solution

For those of you who have recently joined this thread, there is a solution that works for syncing your V650 to a Windows PC:

- switch off all of the protections for your virus checker, or use the settings to exclude the folder C:\Program Files (x86)\Polar\*

- connect your V650

- open the Device Manager (Control Panel->Hardware and Sound->Device Manager) and ***nstall the NDIS Internet Sharing Device

- scan for hardware changes

The USB sync then miraculously works.

You may get a message afterward that the driver installation failed, but repeating the same sequence each time does work. If you had to switch off all the protections, don't forget to turn on the virus checker afterwards!
markss is offline  
Old 10-09-17, 04:46 AM
  #39  
markss
Newbie
 
Join Date: Apr 2017
Posts: 4
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Apologies that this is a repeat of posts from others, but a step by step sequence that you have to do every time might be helpful....
markss is offline  
Old 12-21-17, 07:43 PM
  #40  
edwards1
Newbie
 
Join Date: Sep 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by OldCourierBob View Post
Hi all,

I've been having Polar V650 issues also. I noticed that one thing to try that nobody mentioned is in the "About" section of the V650. You have the option there between Windows and Mac OS X.

However, having said that, I'm at an impasse with my Polar. Won't sync with my Mac anymore, after having done it nicely a bunch of times, nor will it sync with my Samsung Galaxy J3. They can see each other via Bluetooth, but I can't get my data from the Polar.

Does anyone know how to reset the Polar without having to go through the FlowSync application?
I was having the same problem with syncing the V650 with High Sierra. Disabled SIP, reinstalled FlowSync, re-enabled SIP and now I am able to sync. Worth a try!
edwards1 is offline  
Old 06-09-18, 03:13 AM
  #41  
whojammyflip
Newbie
 
Join Date: Jun 2018
Posts: 2
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
I emailed Polar support who gave me this advice, which worked:
1. ***nstall Bonjour (Apple software, which is installed when Flow is installed).
2. ***nstall Polar Flow
3. Reboot computer
4. Install Polar Flow
5. With Flow running, connect V650, switch V650 on, wait a few seconds

At stage 5, my V650 was detected again and everything updated automatically. I was ready to sell my Polar V650 and get a Garmin. This obviously has taken a lot of hassle out of the process. Thanks to my wife for telling me to just email Polar directly.
whojammyflip is offline  
Old 06-14-18, 02:53 AM
  #42  
JosSw
Newbie
 
Join Date: Jun 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Smile post of whojammyflip 06-09-18, 03:13 AM worked for me

post of whojammyflip 06-09-18, 03:13 AM worked for me. Hope that I do not have to do this each time.

I did not have to disable Anti Virus of fill in exceptions, as mentionned in other posts.
JosSw is offline  
Old 06-14-18, 05:09 AM
  #43  
unterhausen
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 18,123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked 24 Times in 22 Posts
welcome to all the helpful newbies. I hope you stick around.
unterhausen is offline  
Old 06-14-18, 07:41 AM
  #44  
TimothyH
- Soli Deo Gloria -
 
TimothyH's Avatar
 
Join Date: Aug 2015
Location: Northwest Georgia
Posts: 13,835

Bikes: 2018 Rodriguez Custom Fixed Gear, 2017 Niner RLT 9 RDO, 2015 Bianchi Pista, 2002 Fuji Robaix

Mentioned: 213 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked 232 Times in 158 Posts
Polar posted this link for sync problems under Windows 10 which is what @whojammyflip posted above.

https://support.polar.com/en/v650-sy...-to-windows-10

The 1.5.4 firmware (April 25, 2018) has made a big difference in reliability of syncing for me.

https://support.polar.com/en/updates...irmware-update


-Tim-
TimothyH is offline  
Old 07-09-18, 08:59 AM
  #45  
iaincd
Newbie
 
Join Date: Jul 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
How do you ***nstall the bonjour software ?

Hi,
I would like to try out your instructions - but where is the bonjour software installed - so I can ***nstall it :-)

Originally Posted by whojammyflip View Post
I emailed Polar support who gave me this advice, which worked:
1. ***nstall Bonjour (Apple software, which is installed when Flow is installed).
2. ***nstall Polar Flow
3. Reboot computer
4. Install Polar Flow
5. With Flow running, connect V650, switch V650 on, wait a few seconds

At stage 5, my V650 was detected again and everything updated automatically. I was ready to sell my Polar V650 and get a Garmin. This obviously has taken a lot of hassle out of the process. Thanks to my wife for telling me to just email Polar directly.
iaincd is offline  
Old 07-16-18, 12:09 AM
  #46  
whojammyflip
Newbie
 
Join Date: Jun 2018
Posts: 2
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
In Windows start menu/search bubble, you need to type in "***nstall program", and that should take you to a list of installed programs from which you can select Bonjour.
whojammyflip is offline  
Old 08-16-18, 04:11 PM
  #47  
olpr
Newbie
 
Join Date: Aug 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Was just having the same problem literally spent all evening trying to get the software to sync. After reading this it occurred to me that there might be some compatibility problem with the software running on Win10.
The fix that I found is Right click on the desktop icon click properties -> Compatibility -> Click 'Run this program in compatibility mode -> Select a version of windows that's not Win10. I chose WinXP as this almost every piece of software written will run on XP.
It works for me.
olpr is offline  
Old 04-08-19, 03:57 AM
  #48  
Andreas74
Newbie
 
Join Date: Apr 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
The first time I tried to sync my Polar V650 it worked with the tip to first ***nstall both bonjour and Polar flow sync programs and then reinstall Polar flow sync. The Polar V650 then synced nicely and updated the firmware. Then I used the V650 for one outdoor cycling training(45km) and then synced it via the Polar flow app on my iphone, which worked. But after that I could not get it to sync to any of my 3 computers again(one is a Mac). I tried every tip above, including trying to manually install the driver for Remote NDIS based internet sharing device manually, but keep getting error code 10 "cannot start device correctly".

I was just about to send the ***t in to Polar, but when preparing for that I tried using the original usb micro cable supplied with the Polar V650 and it worked! I had used three different micro USB cables when problem solving, all cables are functional to other devices. So it seems that the Polar V650 is very sensitive to what USB cable that is used.

My tip: Only use the USB cable that was included in the polar V650 package.
Andreas74 is offline  
Old 05-18-19, 11:45 PM
  #49  
joeypo
Newbie
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Thumbs up ***nstall Boujour app

Originally Posted by whojammyflip View Post
I emailed Polar support who gave me this advice, which worked:
1. ***nstall Bonjour (Apple software, which is installed when Flow is installed).
2. ***nstall Polar Flow
3. Reboot computer
4. Install Polar Flow
5. With Flow running, connect V650, switch V650 on, wait a few seconds

At stage 5, my V650 was detected again and everything updated automatically. I was ready to sell my Polar V650 and get a Garmin. This obviously has taken a lot of hassle out of the process. Thanks to my wife for telling me to just email Polar directly.
Thanks so much this worked for me. I tried everything else. It worked after I ***nstalled the Boujour app. I would have never thought to do that. After the Flowsync app connects and then prompts to install the Boujour app. Now the syncing works.
joeypo is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.