Go Back  Bike Forums > Bike Forums > Road Cycling
Reload this Page >

Di2 battery life?

Notices
Road Cycling “It is by riding a bicycle that you learn the contours of a country best, since you have to sweat up the hills and coast down them. Thus you remember them as they actually are, while in a motor car only a high hill impresses you, and you have no such accurate remembrance of country you have driven through as you gain by riding a bicycle.” -- Ernest Hemingway

Di2 battery life?

Old 09-13-21, 02:02 PM
  #1  
Ogsarg
Senior Member
Thread Starter
 
Join Date: Feb 2017
Location: Hollister, CA (not the surf town)
Posts: 1,406

Bikes: 2019 Specialized Roubaix Comp Di2, 2009 Roubaix, early 90's Giant Iguana

Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 534 Post(s)
Liked 807 Times in 346 Posts
Di2 battery life?

I got my 19 Roubaix Comp in December of 2020 and it probably has about 4000 miles on it. I generally ride it on the weekends and have another bike that gets ridden during the week. I would usually put the charger on it every month or so even though it was not showing low. On a ride yesterday after 11 miles it went into low battery mode where it goes to the small ring in front and the rear continuous to work. I rode another 30 miles and put it on the charger when I got home. As of this morning it is still not showing a full charge so thinking the battery is shot. Doesn't seem right that the battery wouldn't last at least 2 years.

Is there something else that would cause this problem that I should be looking at?
Ogsarg is offline  
Old 09-13-21, 02:10 PM
  #2  
Iride01
Hits [ENTER] b4 thinking
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 8,250

Bikes: '20 Tarmac Disc Comp '91, '78 Raleigh Competition GS

Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 3250 Post(s)
Liked 1,842 Times in 1,308 Posts
How many mA is your chargers output? If you are charging through the PC usb port, then you might be quite a while if at all.

I don't charge mine until it fails to shift the front. Unless maybe I have a really important to me ride the next day and it's been a while.

I generally use the same 2.4 mA output adapter I use to charge my phone.
Iride01 is offline  
Old 09-13-21, 05:26 PM
  #3  
tempocyclist
Senior Member
 
tempocyclist's Avatar
 
Join Date: Jun 2021
Location: Australia
Posts: 158

Bikes: 2002 Trek 5200 (US POSTAL), 2020 Canyon Aeroad SL

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 52 Post(s)
Liked 135 Times in 63 Posts
Either the battery is shot, your charger is shot or there's a loose/dirty connection somewhere. Firstly, try a different USB charging pack if you can and plug into the wall not a computer or power bank.

I've got roughly 25,000km on my original Di2 battery and get an easy 2000km from a charge (I never let it go as low as limp-home mode).
tempocyclist is offline  
Old 09-13-21, 06:25 PM
  #4  
rm -rf
don't try this at home.
 
rm -rf's Avatar
 
Join Date: Jan 2006
Location: N. KY
Posts: 5,304
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 728 Post(s)
Liked 117 Times in 86 Posts
The charger light goes out when it's done charging. I don't watch mine, but it seems to take just a couple of hours at the most with an old 1.3A wall charger.

There's been a few comments on BF of failed Di2 batteries this summer.

My original battery lasted more than 5 years, and was still working, but I had to recharge it quite often during the final year. The replacement battery has been fine for a few years now. I have about 30,000 miles on the bike now, and everything still works like new.
rm -rf is offline  
Old 09-14-21, 11:16 AM
  #5  
Ogsarg
Senior Member
Thread Starter
 
Join Date: Feb 2017
Location: Hollister, CA (not the surf town)
Posts: 1,406

Bikes: 2019 Specialized Roubaix Comp Di2, 2009 Roubaix, early 90's Giant Iguana

Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 534 Post(s)
Liked 807 Times in 346 Posts
I had a few minutes to look at the bike this morning. I noticed that one of the two pins in the charging port (bar end type) is more recessed than the other and perhaps the connection is intermittent.

Can anyone confirm that the two pins are recessed the same or different? I saw last night the batter is $160.00 and I certainly don't want to buy one if not necessary.
Ogsarg is offline  
Old 09-14-21, 11:27 AM
  #6  
Iride01
Hits [ENTER] b4 thinking
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 8,250

Bikes: '20 Tarmac Disc Comp '91, '78 Raleigh Competition GS

Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 3250 Post(s)
Liked 1,842 Times in 1,308 Posts
Nope. Each pin same length on mine.

You are using the SM-BCR2 aren't you? What are you connecting it too for power?
Iride01 is offline  
Old 09-14-21, 04:24 PM
  #7  
Sy Reene
Advocatus Diaboli
 
Sy Reene's Avatar
 
Join Date: Feb 2015
Location: Wherever I am
Posts: 7,335

Bikes: Merlin Cyrene, Nashbar steel CX

Mentioned: 11 Post(s)
Tagged: 1 Thread(s)
Quoted: 3917 Post(s)
Liked 963 Times in 644 Posts
Originally Posted by Ogsarg View Post
Is there something else that would cause this problem that I should be looking at?
Planned obsolescence
Sy Reene is offline  
Old 09-14-21, 04:41 PM
  #8  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 5,148

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel

Mentioned: 16 Post(s)
Tagged: 0 Thread(s)
Quoted: 2010 Post(s)
Liked 737 Times in 455 Posts
Originally Posted by Ogsarg View Post
I had a few minutes to look at the bike this morning. I noticed that one of the two pins in the charging port (bar end type) is more recessed than the other and perhaps the connection is intermittent.

Can anyone confirm that the two pins are recessed the same or different? I saw last night the batter is $160.00 and I certainly don't want to buy one if not necessary.

I've been charging 4 years or so, never had issues with the charging cable. The charger does want X amount of power, a good quality wall wart and right to a real outlet is recommended.
Steve B. is offline  
Old 09-14-21, 08:40 PM
  #9  
blakcloud 
Senior Member
 
blakcloud's Avatar
 
Join Date: Aug 2007
Location: Toronto, Ontario
Posts: 2,565

Bikes: Trek Domane SL7, Rivendell Sam Hillborne, Winter Cycles flat bar road bike, Brompton S/M3L (modified)

Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 597 Post(s)
Liked 327 Times in 210 Posts
If it is the battery you might want to look at a warranty claim. The battery is warranted for two years.
blakcloud is offline  
Old 09-15-21, 10:39 AM
  #10  
Ogsarg
Senior Member
Thread Starter
 
Join Date: Feb 2017
Location: Hollister, CA (not the surf town)
Posts: 1,406

Bikes: 2019 Specialized Roubaix Comp Di2, 2009 Roubaix, early 90's Giant Iguana

Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 534 Post(s)
Liked 807 Times in 346 Posts
Well. I got the battery charged now. I think the recessed pin was causing an intermittent connection and that causes the charger to stop charging until it gets unplugged and plugged back in. I may look at a warranty claim for the bar end junction box since it is a hundred bucks. But for now, I know what I need to do when charging.

Thanks for all the advice.
Ogsarg is offline  
Old 09-15-21, 11:36 AM
  #11  
rm -rf
don't try this at home.
 
rm -rf's Avatar
 
Join Date: Jan 2006
Location: N. KY
Posts: 5,304
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 728 Post(s)
Liked 117 Times in 86 Posts
I wrap a turn or two of the charge cable around my handlebar before I plug it into the bike -- that takes all the strain off the cable plug. Perhaps your cable is getting pulled loose enough to stop charging.

My charger port on the junction box (made in 2014) under my stem has the right hand pin recessed more than the left one. It still works fine. The charge plug clicks in easily, there's no tricks to getting it seated fully. Maybe the short pin is designed on purpose? Check a different bike with Di2 and see if it's pins are similar.

I see that the charging light on my SM-BCR2 won't come on until it's connected to the bike--good. I used a silver sharpie on the box to note "LED ON=charging", when I first got it, and colored the top side of the charge plug in silver--it's not obvious which way is "up", and the plug is keyed so it can't insert upside down. I've never seen the other "Error" light on the charge box lit up--good!

Last edited by rm -rf; 09-15-21 at 11:39 AM.
rm -rf is offline  
Old 09-15-21, 11:47 AM
  #12  
rm -rf
don't try this at home.
 
rm -rf's Avatar
 
Join Date: Jan 2006
Location: N. KY
Posts: 5,304
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 728 Post(s)
Liked 117 Times in 86 Posts
Originally Posted by Iride01 View Post
How many mA is your chargers output? If you are charging through the PC usb port, then you might be quite a while if at all.

I don't charge mine until it fails to shift the front. Unless maybe I have a really important to me ride the next day and it's been a while.

I generally use the same 2.4 mA output adapter I use to charge my phone.
Lithium batteries don't need to be drained toward empty. I only check my battery charge occasionally, and charge it soon after it goes from solid green to blinking green. That's at the 50% charge level. I've only twice forgotten to check often enough to get where the front quits shifting. (I usually think to check while I'm riding--that works easily, it's just holding down the front shift button for 5 seconds.)

An old 1.3A phone wall charger works fine. I just keep it connected to the Di2 charge cable--very convenient.
rm -rf is offline  
Old 09-15-21, 03:14 PM
  #13  
Iride01
Hits [ENTER] b4 thinking
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 8,250

Bikes: '20 Tarmac Disc Comp '91, '78 Raleigh Competition GS

Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 3250 Post(s)
Liked 1,842 Times in 1,308 Posts
Originally Posted by rm -rf View Post
Lithium batteries don't need to be drained toward empty. I only check my battery charge occasionally, and charge it soon after it goes from solid green to blinking green. That's at the 50% charge level. I've only twice forgotten to check often enough to get where the front quits shifting. (I usually think to check while I'm riding--that works easily, it's just holding down the front shift button for 5 seconds.)

An old 1.3A phone wall charger works fine. I just keep it connected to the Di2 charge cable--very convenient.
I didn't know I could drain a battery toward full. <grin>
Iride01 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.