Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

Garmin 830 not getting texts

Notices
Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

Garmin 830 not getting texts

Old 10-05-19, 08:21 PM
  #1  
Jakedatc
Senior Member
Thread Starter
 
Jakedatc's Avatar
 
Join Date: Oct 2007
Location: CT
Posts: 3,054
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 10 Times in 7 Posts
Garmin 830 not getting texts

For some reason I am not getting text notifications on my 830 like it is supposed to. do I need to pair it with my phone every ride if i want that to happen?

trying to figure out the fun bells and whistles..
Jakedatc is offline  
Old 10-06-19, 12:34 AM
  #2  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
I have one and I'm happy with it but the Bluetooth connection is finicky and perhaps that's your issue.

When I'm first about to start a ride, the Bluetooth won't connect. Opening the Garmin Connect account on my phone pairs them almost right away and they'll stay paired the rest of the ride, even if I close Garmin Connect. Perhaps that's your issue.
tunavic is offline  
Old 10-06-19, 05:57 AM
  #3  
Jakedatc
Senior Member
Thread Starter
 
Jakedatc's Avatar
 
Join Date: Oct 2007
Location: CT
Posts: 3,054
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 10 Times in 7 Posts
Ok i'll give it a try. the rest has been great so far..
Jakedatc is offline  
Old 10-06-19, 07:52 AM
  #4  
unterhausen
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 23,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked 2,853 Times in 1,962 Posts
Originally Posted by tunavic View Post
I have one and I'm happy with it but the Bluetooth connection is finicky and perhaps that's your issue.
Just curious, do you have an Android or iOS phone?

I'm not sure I have ever gotten a text on my bike, I should ask someone to send me one.
unterhausen is offline  
Old 10-06-19, 08:00 AM
  #5  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
Originally Posted by unterhausen View Post
Just curious, do you have an Android or iOS phone?

I'm not sure I have ever gotten a text on my bike, I should ask someone to send me one.
Android. I receive texts no problem if the Bluetooth connection is made
tunavic is offline  
Old 10-06-19, 08:27 AM
  #6  
unterhausen
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 23,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked 2,853 Times in 1,962 Posts
Well, that blows my theory that bluetooth problems are only on iOS

My 830 seems to upload my rides no problem, although I haven't figured out how. But it seems like it is over bluetooth through my phone. I'm thinking one of us is going to have to read the manual on how to get texts.
unterhausen is offline  
Old 10-06-19, 09:56 AM
  #7  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
Originally Posted by unterhausen View Post
Well, that blows my theory that bluetooth problems are only on iOS

My 830 seems to upload my rides no problem, although I haven't figured out how. But it seems like it is over bluetooth through my phone. I'm thinking one of us is going to have to read the manual on how to get texts.
Edit: It will use Bluetooth to upload rides using your cell phone.

We're having different issues.

My 830 and phone don't always connect automatically, as they should. If I open the Connect app, it connects almost right away.

Once connected, I always get my text messages.

It seems you have a different problem. You're connected to the phone and rides are uploading but you're not getting text messages. Is that correct?

If that's the case, after your phone is connected to your 830, go to "connected features, phone then smart notifications. There you can toggle on or off the features you want to be notified about. Text, calls, social media and other. Those four can be toggled on or off. I suspect your "text" is toggled to off.

Good luck

Last edited by tunavic; 10-06-19 at 10:08 AM.
tunavic is offline  
Old 10-06-19, 01:15 PM
  #8  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 6,165

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel, Specialized Epic Evo

Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 2745 Post(s)
Liked 1,477 Times in 858 Posts
Possibly the Blue Tooth Low Energy connection isn’t being made. On an iOS phone there were 2 different BT connections to the phone, from my 810, my 1000 and my 1030. The primary BT was called “Edge XXX” and dealt with the basic connection that allowed the completed track upload to the Connect Mobile app as well as Route/Course downloads to the device. The BLE connection, as far as I could determine, dealt with “live” functions such as LiveTrack and notifications as it wasn’t dependent on a button push on the device (Save) or in GCM (send to device). Garmin changed the BT connections in v8 for the 1030, they are now both called “Edge 1030”, which is just really confusing. I do see on my 1030 that almost always I have to go into the iOS BT section and do a manual connection for the 2nd BT connection in order to function. Sometimes it refuses to connect and I get no Live Track. This is the ongoing BT issue that Garmin has had going back at least 2 years with assorted devices and that DC Rainmaker called them out on and that they still have not fixed.
Steve B. is offline  
Likes For Steve B.:
Old 10-06-19, 11:58 PM
  #9  
Seattle Forrest
Senior Member
 
Seattle Forrest's Avatar
 
Join Date: Mar 2010
Location: Seattle, WA
Posts: 23,208
Mentioned: 87 Post(s)
Tagged: 0 Thread(s)
Quoted: 18880 Post(s)
Liked 10,640 Times in 6,050 Posts
This isn't an uncommon complaint about their bike computers, but everyone I know with any of their watches echos my experience that BT is 100% reliable 24/7/365. They should circle the wagons internally, figure out what's going wrong for some users, and fix it.
Seattle Forrest is offline  
Old 10-07-19, 08:37 AM
  #10  
Ald1 
Senior Member
 
Join Date: May 2017
Location: Central Pa.
Posts: 293

Bikes: Domane SLR 9 Fuji Gran Fondo 2.3 1978 Mercian

Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 145 Post(s)
Liked 15 Times in 7 Posts
Well, my 1030 has recently (the time of the 1030 upgrade) not to connect well at all and, of course also not display texts which it was doing quite reliably. My phone shows the 1030 connected. The Garmin app shows it NOT connected. BTW I'm using an apple phone sofeware version 12.4.1. I'll be upgrading to ver 13 soon but Garmin has already sent an email that this upgrade is causing connection problems. In this day, with all that connects via bluetooth why Garmin has these issues. PS I also deleted and repaired the two with NO improvement.
Ald1 is offline  
Old 10-08-19, 09:52 AM
  #11  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
@Jakedatc and @unterhausen any success getting your text messages?
tunavic is offline  
Old 10-08-19, 02:52 PM
  #12  
unterhausen
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 23,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked 2,853 Times in 1,962 Posts
you're going to make me read the manual, aren't you? A friend pointed out I don't get any texts because nobody likes me. He forgot about CVS
unterhausen is offline  
Old 10-08-19, 10:07 PM
  #13  
Seattle Forrest
Senior Member
 
Seattle Forrest's Avatar
 
Join Date: Mar 2010
Location: Seattle, WA
Posts: 23,208
Mentioned: 87 Post(s)
Tagged: 0 Thread(s)
Quoted: 18880 Post(s)
Liked 10,640 Times in 6,050 Posts
Originally Posted by Ald1 View Post
Well, my 1030 has recently (the time of the 1030 upgrade) not to connect well at all and, of course also not display texts which it was doing quite reliably. My phone shows the 1030 connected. The Garmin app shows it NOT connected. BTW I'm using an apple phone sofeware version 12.4.1. I'll be upgrading to ver 13 soon but Garmin has already sent an email that this upgrade is causing connection problems. In this day, with all that connects via bluetooth why Garmin has these issues. PS I also deleted and repaired the two with NO improvement.
For what it's worth, a lot of apps use Bluetooth to spy on you. For a long time now people have been able to prevent apps from using GPS location to track you, but they can get around that using BT. Seriously, Dunkin Donuts uses BT to track how often you're in their stores. Facebook is even creeper about it. As a result, Apple cracked down in iOS 13, and made it a lot easier to deny apps the ability to use BT including in the background. For non-technical users, is easy to disable an app's Animoto to use BT without much thought. Garmin has to support every type of user with every level of technical knowledge. It's very common for companies to give blanket advice meant to reduce the need for support.
Seattle Forrest is offline  
Old 10-08-19, 11:06 PM
  #14  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
Originally Posted by unterhausen View Post
you're going to make me read the manual, aren't you? A friend pointed out I don't get any texts because nobody likes me. He forgot about CVS
Originally Posted by tunavic View Post
Edit: It will use Bluetooth to upload rides using your cell phone.

We're having different issues.

My 830 and phone don't always connect automatically, as they should. If I open the Connect app, it connects almost right away.

Once connected, I always get my text messages.

It seems you have a different problem. You're connected to the phone and rides are uploading but you're not getting text messages. Is that correct?

If that's the case, after your phone is connected to your 830, go to "connected features, phone then smart notifications. There you can toggle on or off the features you want to be notified about. Text, calls, social media and other. Those four can be toggled on or off. I suspect your "text" is toggled to off.

Good luck
No need to read the manual unless you like boring reading

Curious if my suggestion above solved your issue.

Also, CVS doesn't like you, just your cash
tunavic is offline  
Old 10-09-19, 04:56 AM
  #15  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 6,165

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel, Specialized Epic Evo

Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 2745 Post(s)
Liked 1,477 Times in 858 Posts
Originally Posted by Ald1 View Post
Well, my 1030 has recently (the time of the 1030 upgrade) not to connect well at all and, of course also not display texts which it was doing quite reliably. My phone shows the 1030 connected. The Garmin app shows it NOT connected. BTW I'm using an apple phone sofeware version 12.4.1. I'll be upgrading to ver 13 soon but Garmin has already sent an email that this upgrade is causing connection problems. In this day, with all that connects via bluetooth why Garmin has these issues. PS I also deleted and repaired the two with NO improvement.
I'm thinking that not having the Garmin Connect Mobile app actually running is a cause of many connection problems. My new 1030 was hit and miss at not automatically making the 2nd "Edge 1030" BLE connection. I would have to dive into the phone BT settings and manually try to pair. Sometimes it wouldn't no matter how many times. Then a re-read of Tunavics post made me think and last night I tried 4 connection tests only this time making sure GCM was ON each time, with the 1030 now automatically connecting successfully. I am aware that on occasion I do a "swipe up" on the iPhone of a lot of apps and am aware that GCM gets closed a lot. I've not yet tested if the B T stays connected for ride but this feels like a step in the right direction.
Steve B. is offline  
Old 10-09-19, 06:09 AM
  #16  
Ald1 
Senior Member
 
Join Date: May 2017
Location: Central Pa.
Posts: 293

Bikes: Domane SLR 9 Fuji Gran Fondo 2.3 1978 Mercian

Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 145 Post(s)
Liked 15 Times in 7 Posts
Well my connect problems were with GCM running. My phone showed it connected in the bluetooth settings but the GCM app showed it not connected as did the head unit. I've since upgraded the phone to ver. 13 and it seemed to connect well in the house. I've yet to ride due to a bad cold I'm trying to shake.
Ald1 is offline  
Old 10-09-19, 05:02 PM
  #17  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
@Steve B. My 830 rarely connects automatically but I've learned that simply opening the Garmin Connect Mobile app will connect the phone every single time and it stays connected even if I close the GCM app. And uploads automatically too.

Having said that, take note the the new iPhone Pro with io 13.1 is having connection issues with some Garmin forum users.

Edit: There's also a beta version of 830 software available now (4.21) that says it fixes phone connection issues with iPhone 11 Here's a link

https://forums.garmin.com/sports-fit...-now-available

Last edited by tunavic; 10-09-19 at 05:09 PM.
tunavic is offline  
Old 10-09-19, 05:08 PM
  #18  
shelbyfv
Expired Member
 
shelbyfv's Avatar
 
Join Date: Jun 2007
Location: TN
Posts: 10,311
Mentioned: 32 Post(s)
Tagged: 0 Thread(s)
Quoted: 3095 Post(s)
Liked 4,143 Times in 2,093 Posts
This is mostly beyond my comprehension but my Edge 530 instructions specifically said that the Bluetooth connection must be made via the Connect app and not through the phone BT. I left the phone (Android) BT unpaired.
shelbyfv is offline  
Old 10-09-19, 05:18 PM
  #19  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
Originally Posted by shelbyfv View Post
This is mostly beyond my comprehension but my Edge 530 instructions specifically said that the Bluetooth connection must be made via the Connect app and not through the phone BT. I left the phone (Android) BT unpaired.
For the initial pairing that is correct but you shouldn't have to open the GCM app every time for the phone to connect. It should happen automatically
tunavic is offline  
Likes For tunavic:
Old 10-09-19, 05:24 PM
  #20  
tunavic
Senior Member
 
tunavic's Avatar
 
Join Date: Jul 2011
Location: Coachella Valley, CA
Posts: 1,121

Bikes: '12 BMC Road Racer, Pinarello KOBH

Mentioned: 75 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked 19 Times in 14 Posts
By the way the current software for the 830 is 4.19 @shelbyfv I believe it's the same for the 530
tunavic is offline  
Likes For tunavic:
Old 10-09-19, 05:28 PM
  #21  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 6,165

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel, Specialized Epic Evo

Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 2745 Post(s)
Liked 1,477 Times in 858 Posts
Originally Posted by shelbyfv View Post
This is mostly beyond my comprehension but my Edge 530 instructions specifically said that the Bluetooth connection must be made via the Connect app and not through the phone BT. I left the phone (Android) BT unpaired.
On iOS, there are and have been 2 separate BT connections. The phone needs to pair via the BT settings in the phone, as well as in Connect. The pairing instructions from Garmin do indicate you also need to do a connection via GCM, but I think I just forget the basics that GCM needs to be running in the background for the notifications, live track, etc... to function. That stuff uses the 2nd BlueTooth Low Energy connection as far as I know. I have at times never started GCM, or checked that it was indeed running, yet have rarely had issues doing a competed ride upload, but will now remember to just open (and make sure itís running) before a ride.

Note though, that even with the GCM app running, there are many reports of folks not getting notifications or having LiveTrack. The BLE connection is flaky and thatís what DCRainmaker describes in his complaint to Garmin.
Steve B. is offline  
Likes For Steve B.:
Old 10-09-19, 05:31 PM
  #22  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 6,165

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel, Specialized Epic Evo

Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 2745 Post(s)
Liked 1,477 Times in 858 Posts
Originally Posted by tunavic View Post
For the initial pairing that is correct but you shouldn't have to open the GCM app every time for the phone to connect. It should happen automatically
Iím now beginning to think you need to do just that, especially if youíve done a forced close of GCM on an iOS device. Reason I think this is I believe that notification and LiveTrack port thru the GCM app and if not running, those functions wonít work. I have to run some tests to determine this,
Steve B. is offline  
Old 10-10-19, 04:41 PM
  #23  
unterhausen
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 23,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked 2,853 Times in 1,962 Posts
so far, the requirement that the app be running checks out. I have not been running it because I find all the notifications annoying. And starting it up when I start a ride hasn't occurred to me. I did find out that my rides are not being updated through my phone. I'm not sure the app ever generates a notification that is of interest, maybe I should just turn them off.
unterhausen is offline  
Old 10-10-19, 06:32 PM
  #24  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 6,165

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel, Specialized Epic Evo

Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 2745 Post(s)
Liked 1,477 Times in 858 Posts
I did a quicky test. Forced close the Garmin app on an iPhone. Booted the 1030. Watched as the 1st 1030 BT was made but not the 2nd. Waited a bit, no 2nd connection. Turned off the 1030, turned On the GCM app, powered up the 1030 and watched as both BT connections were made. I mean, it seems obvious in retrospect to have the app running.
Steve B. is offline  
Old 10-10-19, 06:49 PM
  #25  
Seattle Forrest
Senior Member
 
Seattle Forrest's Avatar
 
Join Date: Mar 2010
Location: Seattle, WA
Posts: 23,208
Mentioned: 87 Post(s)
Tagged: 0 Thread(s)
Quoted: 18880 Post(s)
Liked 10,640 Times in 6,050 Posts
Originally Posted by tunavic View Post
For the initial pairing that is correct but you shouldn't have to open the GCM app every time for the phone to connect. It should happen automatically
This is my experience with Android and Garmin watches. It doesn't matter whether the app is running or not in terms of being able to receive notifications, or sync. There must be a background process taking care of that. Maybe iOS doesn't have/allow that?
Seattle Forrest is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.