Go Back  Bike Forums > Bike Forums > Electric Bikes
Reload this Page >

BIONX - No Pedal Assist

Notices
Electric Bikes Here's a place to discuss ebikes, from home grown to high-tech.

BIONX - No Pedal Assist

Old 05-05-22, 01:18 PM
  #1  
sarma
Newbie
Thread Starter
 
Join Date: May 2022
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
BIONX - No Pedal Assist

Hello,
I put together a Bionx bike - D500 motor, RC3 controller, DS3 display. There is no throttle available, only pedal assist and even the pedal assist does not work. All looks well on the display, battery charges and holds well. The notch on Torque Blocker points down.
I reseated all connections.
I am able to change assist level and regen level on the controller, and there are no errors on the display. Odometer and speedometer work well so I believe the communication with the wheel is ok. Just there is no assist from the motor when I pedal. I even went to higher speeds (over 25 km/h) as someone suggested somewhere that may engage the assist. Nothing helped.
Does anyone have a suggestion what might be wrong or how to test the motor?

Thank you
sarma is offline  
Old 05-05-22, 05:07 PM
  #2  
2old
Senior Member
 
Join Date: Jul 2014
Location: socal
Posts: 3,385
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 669 Post(s)
Liked 452 Times in 345 Posts
BionX had proprietary functions incorporated into their hub systems. ebikesca has developed some "work-around" tricks. FME with other systems they have been helpful. You might contact them.
2old is offline  
Old 05-06-22, 04:37 AM
  #3  
BobG
Senior Member
 
Join Date: Feb 2010
Location: NH
Posts: 920
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 272 Post(s)
Liked 78 Times in 57 Posts
Is it a "new" motor kit from an internet source? Perhaps it was not activated? If not activated you will need to find somebody with BBI bootleg software and a BIB interface device to connect to a computer. Many previous BionX dealers no longer have this. I'm just guessing, hopefully it's something simpler.

BobG is offline  
Old 05-09-22, 12:35 AM
  #4  
sarma
Newbie
Thread Starter
 
Join Date: May 2022
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
It is not a new motor as it shows mileage on it (on the display). It must have been activated already. Maybe after I replaced the display, it now requires another activation?
sarma is offline  
Old 05-09-22, 04:27 AM
  #5  
BobG
Senior Member
 
Join Date: Feb 2010
Location: NH
Posts: 920
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 272 Post(s)
Liked 78 Times in 57 Posts
Originally Posted by sarma View Post
It is not a new motor as it shows mileage on it (on the display). It must have been activated already. Maybe after I replaced the display, it now requires another activation?
If it's a used motor with over 50km on it then activation is not likely the problem.

Was the previous display DS3 or G2? If it used to be G2 then your battery firmware may or may not be compatible. Console code 0002 on my G2 reveals battery firmware version. Not sure how this works on your RC3/DS3. Battery firmware version 12 only works with G2, version 15 works with either G2 or DS3. You'd need a BIB tool and BBI software to change versions.

The fact that your console speaks to the motor suggests that the firmware may be correct, but I'm not sure about this. The wrong firmware will ignore the battery. I'm just throwing out wild suggestions based on 6 years of owning BionX D500s and batteries. I'm not a technician. More likely a bad connection you haven't found yet!

Last edited by BobG; 05-10-22 at 03:36 AM.
BobG is offline  
Old 05-13-22, 09:19 PM
  #6  
sarma
Newbie
Thread Starter
 
Join Date: May 2022
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
I found software online and have ordered the interface. Will post here if I am able to find out the problem.
sarma is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.