Go Back  Bike Forums > News & Suggestions > Forum Suggestions & User Assistance
Reload this Page >

You broke all the links TWICE????

Notices
Forum Suggestions & User Assistance Have a suggestion for the forums? Need help with the Forums? Post here.

You broke all the links TWICE????

Old 07-07-21, 03:47 PM
  #1  
LarryMelman
Senior Member
Thread Starter
 
LarryMelman's Avatar
 
Join Date: Aug 2008
Location: Phoenix, AZ
Posts: 602
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Likes: 0
Liked 1 Time in 1 Post
You broke all the links TWICE????

I have a few threads of interest bookmarked. Last weekend the bookmarks quit working because some genius loaded an upgrade that changed not only the links to each forum, but also the links to each thread. So I figured that out and adjusted my bookmarks.

Today, they are broken again. I assume you put things back to the way they were before.

This is no way to run a railroad, folks.
LarryMelman is offline  
Old 07-07-21, 08:20 PM
  #2  
cb400bill
Follow Your Arrow
 
cb400bill's Avatar
 
Join Date: Jul 2007
Location: Kalamazoo MI
Posts: 19,697

Bikes: Fuji SL2.1 Carbon Di2 Cannondale Synapse Alloy 4 Trek Checkpoint ALR gravel Viscount Aerospace Pro

Mentioned: 46 Post(s)
Tagged: 0 Thread(s)
Quoted: 2517 Post(s)
Liked 3,306 Times in 2,013 Posts
It was a glitch. They fixed the glitch.

Deal with it.
__________________
How did we get here?





cb400bill is offline  
Likes For cb400bill:
Old 07-09-21, 09:04 AM
  #3  
Iride01
Hits [ENTER] b4 thinking
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 8,353

Bikes: '20 Tarmac Disc Comp '91, '78 Raleigh Competition GS

Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 3289 Post(s)
Liked 1,881 Times in 1,337 Posts
Just bookmark the main site. They already have everything "bookmarked" for you once you get here.
Iride01 is offline  
Likes For Iride01:
Old 07-10-21, 12:23 PM
  #4  
madpogue 
Senior Member
 
Join Date: Jan 2004
Location: Madison, WI USA
Posts: 5,495
Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 1802 Post(s)
Liked 848 Times in 642 Posts
One apparent bug remains. Here's how to replicate it:
* Set your posts-per-page count to 30
* Navigate to Classic & Vintage, find the Wacky World thread, then navigate to the "Last Page" link for that thread.
You'll get a "Page not found" error; the site thinks there are 680 pages when there are actually only 679.

This does NOT happen when your posts-per-page setting is set to 10. I haven't tested other posts-per-page settings; I figure that if you have an example that works, and one that replicates the issue, that should be enough to troubleshoot.
madpogue is offline  
Old 07-10-21, 12:54 PM
  #5  
CliffordK
Senior Member
 
CliffordK's Avatar
 
Join Date: Nov 2014
Location: Eugene, Oregon, USA
Posts: 26,062
Mentioned: 209 Post(s)
Tagged: 0 Thread(s)
Quoted: 14492 Post(s)
Liked 2,447 Times in 1,821 Posts
Originally Posted by madpogue View Post
One apparent bug remains. Here's how to replicate it:
* Set your posts-per-page count to 30
* Navigate to Classic & Vintage, find the Wacky World thread, then navigate to the "Last Page" link for that thread.
You'll get a "Page not found" error; the site thinks there are 680 pages when there are actually only 679.

This does NOT happen when your posts-per-page setting is set to 10. I haven't tested other posts-per-page settings; I figure that if you have an example that works, and one that replicates the issue, that should be enough to troubleshoot.
The page numbers being off is an error that has been around for quite some time, and is related to deleted posts in some of the longer threads.

For example:
https://www.bikeforums.net/classic-v...y-ads-815.html

Currently lists 816 pages, but only has 815 pages. Clicking on "Last Page" takes one to 815. Likewise, changing the page number in the address bar to anything greater than 815 will take one to the 815 page.

The "Default" appears to be 25 posts per page.
I tried changing my setting to 30 posts per page, and was unable to replicate what you found (PC/firefox).

Is it possible you're hitting a caching (somewhere) issue?

I often like to simply change page numbers in my address bar. If I put in a number past the current number of pages (say 10+ past), and repeatedly use that number, I've found that the system often will keep taking me to the same page number, even if the last page count is increased. If I vary the page number I use, then I go to the last page. This indicates that somewhere the link to the last page is cached.
CliffordK is offline  
Likes For CliffordK:
Old 07-10-21, 12:59 PM
  #6  
CliffordK
Senior Member
 
CliffordK's Avatar
 
Join Date: Nov 2014
Location: Eugene, Oregon, USA
Posts: 26,062
Mentioned: 209 Post(s)
Tagged: 0 Thread(s)
Quoted: 14492 Post(s)
Liked 2,447 Times in 1,821 Posts
Originally Posted by LarryMelman View Post
You broke all the links TWICE????
There were numerous threads about the broken links over the 4th of July weekend.

As moderators and administrators, replied to the threads, but didn't indicate any permanence of the change, many of us waited to see what would happen Tuesday or Wednesday before making any major changes, just in case it went back to "normal".

On a couple of occasions I posted links to other BF threads, and tried to post using both the new and old format, so at least half my links would always work.

Big Thanks to the Bike Forum Staff for resolving the issues!!!
CliffordK is offline  
Old 07-10-21, 02:01 PM
  #7  
madpogue 
Senior Member
 
Join Date: Jan 2004
Location: Madison, WI USA
Posts: 5,495
Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 1802 Post(s)
Liked 848 Times in 642 Posts
Originally Posted by CliffordK View Post
The page numbers being off is an error that has been around for quite some time, and is related to deleted posts in some of the longer threads.

For example:
https://www.bikeforums.net/classic-v...y-ads-815.html

Currently lists 816 pages, but only has 815 pages. Clicking on "Last Page" takes one to 815. Likewise, changing the page number in the address bar to anything greater than 815 will take one to the 815 page.

The "Default" appears to be 25 posts per page.
I tried changing my setting to 30 posts per page, and was unable to replicate what you found (PC/firefox).

Is it possible you're hitting a caching (somewhere) issue?

I often like to simply change page numbers in my address bar. If I put in a number past the current number of pages (say 10+ past), and repeatedly use that number, I've found that the system often will keep taking me to the same page number, even if the last page count is increased. If I vary the page number I use, then I go to the last page. This indicates that somewhere the link to the last page is cached.
Well, the Last Page link worked before the 4th. The same thing happens with the "First Unread" link. It happens on multiple browsers, multiple machines; that doesn't rule out caching, but it puts it low on the suspect list.

When you set your posts-per-page to 30, and float your mouse over the last-page link for Wacky World, what page number appears in the link? I get 680.
madpogue is offline  
Old 07-11-21, 09:12 PM
  #8  
3alarmer
Friendship is Magic
 
3alarmer's Avatar
 
Join Date: Nov 2010
Location: The Big Tomato
Posts: 19,898

Bikes: old ones

Mentioned: 283 Post(s)
Tagged: 0 Thread(s)
Quoted: 21847 Post(s)
Liked 4,736 Times in 3,464 Posts
.
...there used to be better complaints on this forum. I'm going to start a thread complaining about the quality of the complaints. It just seems to me people are phoning it in now.
3alarmer is online now  
Likes For 3alarmer:
Old 07-12-21, 12:35 PM
  #9  
livedarklions
Racerboyz' b'crat
 
livedarklions's Avatar
 
Join Date: Jun 2018
Location: New England
Posts: 9,855

Bikes: Serotta Atlanta; 1994 Specialized Allez Pro; Giant OCR A1; SOMA Double Cross Disc

Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 5095 Post(s)
Liked 4,402 Times in 2,481 Posts
Originally Posted by cb400bill View Post
It was a glitch. They fixed the glitch.

Deal with it.

I want my money ba.....

Never mind.
livedarklions is offline  
Likes For livedarklions:
Old 07-12-21, 12:37 PM
  #10  
livedarklions
Racerboyz' b'crat
 
livedarklions's Avatar
 
Join Date: Jun 2018
Location: New England
Posts: 9,855

Bikes: Serotta Atlanta; 1994 Specialized Allez Pro; Giant OCR A1; SOMA Double Cross Disc

Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 5095 Post(s)
Liked 4,402 Times in 2,481 Posts
Originally Posted by 3alarmer View Post
.
...there used to be better complaints on this forum. I'm going to start a thread complaining about the quality of the complaints. It just seems to me people are phoning it in now.

What's the deal with airline food?
livedarklions is offline  
Likes For livedarklions:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.